Recommended Posts

One observation when studying film images and comparing them against digital is that film got less local edge details. The edges blend into each other in a way that makes the image look softer. Do you have any advice on how to reduce local edge contrast? 

Share this post


Link to post
Share on other sites

The easy answer is one cannot, it's technically too complicated.

However if you want to spend the time processing your videos there is a http://www.vapoursynth.com/ script that attempts to do that and it could be used to reduce typical DVD edge "enhancement". Be prepared to spend time on finding the appropriate parameters for your video and for a processing speed of multiple seconds per frame.

https://github.com/IFeelBloated/Vine

 

Edited by Cary Knoop
  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

...If you don't like the reflection of water hitting the ground at night, you probably don't like the look of digital...

You need to evaluate the image and find ways to bring the different luminance levels closer. By decreasing the contrast so that your black and white levels are closer to each other definitely helps. 

A gentle roll-off woud also help a lot. 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

You need to work with spatial tools, to rework the edges. In Baselight I like to use Sharpen (negative range) and DFuse a lot for that. In Baselight 5 there are now even more powerful tools for that with Texture Equaliser and Texture Blend. They give You a lot more precise control over Your edges, because they disassemble the image into several different frequencies (sharp edges -> soft edges) and let You control each of these frequency bands individually. 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Great techniques, and nice to see that you are actually aware of this and have solutions. Has Davinci Resolve similar texture tools? 

Share this post


Link to post
Share on other sites

There are now Resolve FX, Sharpen, Soften, Edges,... nodes, have tried a bit with them, but not fully.

Some time age I was quite happy with a primitive trick in Resolve for C300 HD to 2K DCP upscale looking more "film like"
1st node Blur 0.55 + opacity of the node 50%
2nd node Blur 0.47-45 (sharpening)

  • Like 3

Share this post


Link to post
Share on other sites

I know it sound ridiculus, but in that combo of lenses/camera (Canon Primes) + C300 (Mark I recording via SDI to ProResHQ) it was feeling more organic on the 2K projection.

Blur is set to 50% opacity, that softens the edges a bit than sharpen made all look better, hard to explain in words.

Share this post


Link to post
Share on other sites
8 hours ago, Thomas Singh said:

Blur, then sharpen? What do you accomplish with that?

one doens't reverse the other in this kind of process, the blur node average pixel values, in that way the edges bleeds into each other as well as the rest of the image, sharpening after that micro contrast an image that has pixel values that are closer together, and while it tries to reverse the blur, at the same time the pixels changed from the original image, so a pixel that "belonged" to the bg now seems part of the fg.

yeah, kind of hard to explain i guess.

in very small amount it mix the image together and sometimes it's even hard to see the result using such small values, so it's not always worth the hassle, it helps with super sharp lenses.

a similiar process i used to do to 3d elements when i was a compositor is to add grain and then denoise (before adding footage grain on top again at the end of the composite) that helped a lot to remove the cg feeling out of it

  • Thanks 1

Share this post


Link to post
Share on other sites

This is really helpful! Is there any way that I can "see" the effect in 02 while working without stringing it to the output? And shouldn't it be a way to feed the blurred edges directly from 02 to the main stream? As it is set up now it seems like if I blur 02, the effect is not passed on. I only see the final effect if I blur the 01. node.

Edited by Thomas Singh

Share this post


Link to post
Share on other sites
2 hours ago, Thomas Singh said:

 As it is set up now it seems like if I blur 02, the effect is not passed on. I only see the final effect if I blur the 01. node.

Node 02 in this workflow is used to get an alpha of the edges of the picture.  You then feed that alpha into a node to blur only the edges.  This is why you apply blur to node 01.  Node 02 is your alpha source and Node 01 is where you do the look to those edges.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, Thomas Singh said:

What smoothing filter are you thinking about?

In image scaling settings.
When resolve downscales a footage, it uses different filters. Default is sharp as far as I know.

  • Thanks 1

Share this post


Link to post
Share on other sites

Arri RAW 6.5k footage. DCI 2k timeline. 200% zoom.
Look at "NEON" lable. Left side of the image - smoother resize filter + sharpen at 48 (where 50 is default). Right - sharper resize filter.

image_2018-04-19_02-34-50.png

Edited by Anton Meleshkevich
  • Like 1

Share this post


Link to post
Share on other sites

Why bother to adjust the sharpen? Would be more interesting to see those two filters without any additional sharpening.

Share this post


Link to post
Share on other sites

I did somethig wrong. Forget about the picture. I'm trying to figure it out.
For some reason grabbing a still makes it sharper than on preview window. But decoding set to full res.

However, it works. But the difference is not so noticeble as on the picture.

Any thoughts about this strange thing? Why grabbed stills sharper than preview window?

Edited by Anton Meleshkevich

Share this post


Link to post
Share on other sites
On 3/2/2018 at 1:01 PM, Paul Dore said:

I tried with various convolution filters and frequency separation, but found that a quick and easy method actually worked the best (in Resolve anyway). 

9Y7Inxah.png

Apply the EdgeDetect plugin to node 02 (a corrector node added to the node graph and connected to the source input), adjust parameters to get your edge alpha, then pipe node 02 RGB output to your main stream (node 01) alpha input, and apply blur. This approach can be adapted to work with channels individually.

Whoa, that's actually fantastic. Thanks
Was using Gaussian Blur on a node with a relatively low strength and blended it. GH5 footage is kinda challenging...
Now using this as a threshold I don't have to deal with any texture loss! 

Edited by Dennis Schmitz

Share this post


Link to post
Share on other sites
On 3/2/2018 at 12:01 PM, Paul Dore said:

I tried with various convolution filters and frequency separation, but found that a quick and easy method actually worked the best (in Resolve anyway). 

9Y7Inxah.png

Apply the EdgeDetect plugin to node 02 (a corrector node added to the node graph and connected to the source input), adjust parameters to get your edge alpha, then pipe node 02 RGB output to your main stream (node 01) alpha input, and apply blur. This approach can be adapted to work with channels individually.

I've been trying to replicate this but can't see to get the alpha from node 02 to appear in node 01 after I've added the EdgeDetect. If I then go to blur node 01 it blurs the entire image, not just the edges. What am I missing?

Screen Shot 2020-01-17 at 08.34.15.png

Screen Shot 2020-01-17 at 08.36.58.png

Share this post


Link to post
Share on other sites
(edited)

You need to connect RGB to alpha, not alpha to alpha.

Edited by Jussi Rovanperä
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Jussi Rovanperä said:

You need to connect RGB to alpha, not alpha to alpha.

Ah got you thanks for the help Jussi!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.