Amada Daro

Alpha graphics jagged edges in DaVinci Resolve

Recommended Posts

I have imported a PNG file in DaVinci Resolve and the edges are jagged. The original file is fine and it looks perfect in After Effects. Is there a setting I have missed?  

Share this post


Link to post
Share on other sites

Yes. On media page right click the graphics file, go to 'clip attributes' and under alpha choose 'premultiplied'.

Share this post


Link to post
Share on other sites

Thanks but it's already set to Premultiplied. A bit strange behaviour though, as switching between straight and premultiplied inverts some of the elements which is not what happens when doing the same thing in After Effects.

Share this post


Link to post
Share on other sites

Try adding it within the Fusion page and merge there. That should work. Previous versions of Resolve had problems composting files with an alpha in the Edit page. Sometimes just rendering a cache would fix it. 

  • Thanks 1

Share this post


Link to post
Share on other sites

I just tested this on the Edit Page and it works fine for me (R16.2, MacBookPro Mojave).

  • Thanks 1

Share this post


Link to post
Share on other sites

Seems like the issue is because the graphic is scaled down and re positioned. I have changed scaling from sharper to smoother but it doesn't help much. It looks find when still but looks really bad when  hitting play.

Share this post


Link to post
Share on other sites
(edited)

You need to go into /davinciresolve/preferences/playbacksettings and uncheck "optimized sizing". It's a bug that has been there for a long time and it's doing the exact opposite of optimizing sizing.

Edited by Abby Bader
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

And don't forget to uncheck "force sizing to highest quality" when rendering if you have it enabled.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.